You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
gabbie 9e38abfe88 Merge pull request 'Preparing for database migration' (#17) from code-cleanup into master 4 weeks ago
.vscode Angelo fixing his README (barely) 3 years ago
config Split of 2021 datasheet version 1 year ago
db_migrations Initial changes to support legacy Access data 7 months ago
flow-typed/npm fix typing and building issues 3 years ago
ui Fix typo 4 months ago
.babelrc Upgrade packages to support optional chaining 3 years ago
.env.development fetch data! 3 years ago
.eslintrc.js cleanup 3 years ago
.flowconfig Upgrade packages to support optional chaining 3 years ago
.gitignore ignore another cache 3 years ago
Procfile Fix socket 3 years ago
README.md README update 4 weeks ago
app.py Add error for duplicate colony/date 8 months ago
latest.dump Preparing for database migration 4 months ago
package.json Fix date parsing issue in Safari 2 years ago
requirements.txt fetch data! 3 years ago
runtime.txt upgrade python version 3 years ago
test.dump Preparing for database migration 4 months ago
yarn.lock Fix date parsing issue in Safari 2 years ago

README.md

DB Setup

Load load.sql.

Run Dev Env

Setup

  • Install Node.js
  • Install Python3
  • Install yarn
yarn

Server

Setup

python3 -m venv .venv
. .venv/bin/activate
pip install -r requirements.txt

Handy in case of problems: https://stackoverflow.com/questions/26288042/error-installing-psycopg2-library-not-found-for-lssl

Run

yarn flask

JS

yarn dev